맥 OSX에서 Python 3.5 이상 버전 설치 후 IDLE 실행하면, tcl/tk 오류 해결 방법

운영 환경
10.12.6 (Sierr) (latest: High Sierra)
Python Version” 3.6.1 (latest: 3.6.3)

위 환경에서 python IDLE를 실행하면 아래와 같은 오류가 발생 합니다.

WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable. Visit http://www.python.org/download/mac/tcltk/ for current information.

오류 내용대로라면, tcl/tk 최신 버전만 설치하면, 모든 문제가 해결될걸로 보여지지만, 막상 위 웹 페이지로 접속해서 가장 최신 버전인 8.6.7을 설치해도 동일한 오류 화면이 나오면 당황하게 됩니다. 너무 당황하지 마시고, 8.5.18 버전을 설치하시면 해당 문제가 해결 됩니다.

왜 그러는지 모르겠지만, 8.5 다운로드 링크를 눌러 들어가면서, 8.6.7 최신 버전을 다운로드 가능한 페이지로 전환되어 아무 생각없이 최신 버전을 설치하게되지만, 문제 해결이 안됩니다. 아래 그림과 같이 페이지 하단 부분에 별도로 링크되어 있는 Archinve 페이지에서 8.5.18 버전을 다운로드 받아 설치하시면 문제가 해결 됩니다.

 

1512957579 768x582

Share

댓글 남기기

이메일은 공개되지 않습니다.

Post comment